WWW.lllT.neT下边由phpstorm实例教程频道给各位详细介绍处理phpStorm应用vue提醒"Attribute v-xxx is not allowed here"的方式,期待对必须的小伙伴有些协助!

怎么解决phpStorm应用vue提醒"Attribute v

处理phpStorm应用vue提醒"Attribute v-xxx is not allowed here"的问题

jetbrains大家族的新版本webStorm、phpStorm等专用工具早已适用vue,不用自身再组装Vue.js插件,对vue单文件部件适用挺不错。
可是在html文档中立即<script>引进的形式应用vue时IDE很有可能默认设置不兼容vue的编码提醒补齐,还会继续有 "Attribute v-xxx is not allowed here"那样的提醒,如下图那样
怎么解决phpStorm应用vue提醒"Attribute v

参照jetbrains的vue.js插件源代码表明里边这句话:

  1. If you’re using IntelliJ IDEA Ultimate, PhpStorm, PyCharm, or RubyMine, install Vue.js plugin in Preferences | Plugins - Install JetBrains plugins.
  2. Open your Vue project.
  3. Make sure that you have Vue.js library files in your project (for example, in the node_modules folder).

看上边第3条,就是当今IDE新项目里必须有vue的元件库,例如在node_modules文件目录里。
大家各自应用下边二种方式完成:

1.在线下载vue源代码,合适远程服务器沒有git,npm,vue-cli自然环境的
前去github在线下载vue源代码, 放进新项目文件目录里就可以了。(假如在线下载的是zip请先缓解压力)

2.新创建一个vue-cli新项目,合适远程服务器有npm, vue-cli自然环境的
新创建一个vue-cli新项目, 例如:vue init webpack vue-cli-test,依据提醒建立完并npm install进行以后在同一个ide对话框中开启刚新创建的vue-cli新项目就可以。

无论哪一种方式目地是为了更好地让当今ide对话框中有vue元件库,随后问题就解决了,v-xxx特性不兼容的提醒早已没了,v-for这类的命令里的js代码也适用高亮度了。

怎么解决phpStorm应用vue提醒"Attribute v

(这儿说白了新项目指的仅仅在phpStorm同一个对话框中开启的好几个文件目录罢了,只需这种列表中随意一个里有包括vue的node_modules就可以,例如我这里一般新项目是html-project, 这一新项目里vue是在html文档中根据<script>立即引进应用的。当今phpStrom里与此同时含有的另一个新项目vue-cli-test是vue-cli应用webpack模版新创建的一个空新项目,这一新项目的node_modules里有vue,拥有这一之后html-project新项目里html文档适用vue英语的语法提醒了。)

以上便是怎么解决phpStorm应用vue提醒"Attribute v-xxx is not allowed here"的问题的详尽具体内容,大量请关心自学java网其他相关文章!

WWW.lllT.neT
标签: 工具使用
下载本文:怎么解决phpStorm应用vue提醒"Attribute v.doc

声明:有的资源来自网络转载,版权归原作者所有,如有侵犯到您的权益请联系邮箱:our333@126.com我们将配合处理!

原文地址:怎么解决phpStorm应用vue提醒"Attribute v发布于2021-12-18 13:45:01

相关推荐